Filter
Exclude
Time range
-
Near
31 Oct 2025
YO CT Fungible vs. Non-Fungible Tokens Fungible tokens (e.g., ETH) are interchangeable, like dollars. Non-fungible tokens (NFTs) are unique, like a one-of-a-kind painting. #TokenTypes #Web3
9
1
9
87
Utility vs. Security Tokens explained by Dtoc! 🔧 Utility powers platforms, Security represents assets. Learn more at dtoc.io #Web3 #TokenTypes #Blockchain #DtoC
2
12
6 Feb 2025
Token hunting in Entra ID can be tricky in many scenarios, whether for an access token, refresh token, etc. Sometimes, we could have a blindspot, especially when using Access Token. There are multiple ways to hunt and detect token usage (reuse/theft/etc.) in Entra ID. Still, how can we search for the refresh token? One way is to use the fields of IncomingTokenType and the UniqueTokenIdentifier. The following query can hunt for potential token reuse based on the fields of UniqueTokenIdentifier and IncomingTokenType. -------------------------------------------------- SigninLogs | where isnotempty(UniqueTokenIdentifier) and isnotempty(IncomingTokenType) | extend Browser = tostring(parse_json(DeviceDetail).browser), OS = tostring(parse_json(DeviceDetail).operatingSystem), IPAddress = tostring(parse_json(NetworkLocationDetails)[0].ipAddress), Location = strcat(tostring(parse_json(Location).countryOrRegion), " - ", tostring(parse_json(Location).city)), MFA_Status = tostring(Status.additionalDetails), TimeStamp = TimeGenerated | project UserPrincipalName, UniqueTokenIdentifier, IncomingTokenType, Browser, OS, IPAddress, Location, TimeStamp, AuthenticationRequirement, ConditionalAccessStatus, MFA_Status | summarize FirstSeen = min(TimeStamp), LastSeen = max(TimeStamp), DeviceCount = dcount(OS), BrowserCount = dcount(Browser), IPCount = dcount(IPAddress), LocationCount = dcount(Location), TokenTypeCount = dcount(IncomingTokenType), SessionCount = count(), Devices = make_set(OS), Browsers = make_set(Browser), IPs = make_set(IPAddress), Locations = make_set(Location), TokenTypes = make_set(IncomingTokenType) by UserPrincipalName, UniqueTokenIdentifier | where DeviceCount > 1 or BrowserCount > 1 or IPCount > 1 or LocationCount > 1 or TokenTypeCount > 1
3
32
170
12,148
14 Mar 2024
Replying to @msexcel
Well, here's a lambda I wrote for figuring out all the cells/ranges/range names that a formula in a cell refers to: =LAMBDA(cell,LET( TOKENIZEFORMULA, LAMBDA(formula_cell,LET( Formula, FORMULATEXT(formula_cell), Chars, MID(Formula,SEQUENCE(LEN(Formula)),1), PriorChars, IFERROR(MID(Formula,SEQUENCE(LEN(Formula),,0),1),""), PriorPriorChars, IFERROR(MID(Formula,SEQUENCE(LEN(Formula),,-1),1),""), NextChars, IFERROR(MID(Formula,SEQUENCE(LEN(Formula),,2),1),""), IsQuote, Chars="""", QuoteCount, SCAN(0,IsQuote,LAMBDA(tot,x,tot x)), NotInQuote, NOT(IF((QuoteCount=1)*IsQuote,FALSE,IF(ISODD( QuoteCount),TRUE,IF(IsQuote*(NextChars="""")*(QuoteCount>0),TRUE,FALSE)))), IsOpenParen, (Chars="(")*NotInQuote, IsCloseParen, (Chars=")")*NotInQuote, IsNotExponent, NotInQuote*(((Chars=" ") (Chars="-"))>0)*(PriorChars="E")*NOT(ISERROR(VALUE(PriorPriorChars)))*NOT(ISERROR(VALUE(NextChars)))=0, IsComparison, ((Chars="<") (Chars=">") (Chars="="))*NotInQuote*(PriorChars<>"")>0, OperatorList, {" ";"-";"*";"/";"^";"&"}, IsOperator, BYROW(Chars,LAMBDA(x,OR(x=OperatorList)))*NotInQuote*IsNotExponent<>0, IsOpenArray, (Chars="{")*NotInQuote, IsCloseArray, (Chars="}")*NotInQuote, ArrayCount, SCAN(0,IsOpenArray-IsCloseArray,LAMBDA(tot,x,tot x)), InArray, ArrayCount>0, IsArgSeperator, (Chars=",")*NotInQuote*(1-InArray)>0, IsArrayColSeperator, (Chars=",")*InArray>0, IsArrayRowSeperator, (Chars=";")*InArray>0, IsWhiteSpace, ((Chars=" ") (Chars=CHAR(10)) (Chars=CHAR(13)))*NotInQuote>0, TokenTypePass1, IFS((Chars="=")*(PriorChars=""),"Formula Begin",IsOpenParen,"Open Paren",IsCloseParen,"Close Paren",IsComparison,"Comparison",IsOperator,"Operator",IsOpenArray,"Open Array",IsCloseArray,"Close Array",IsArgSeperator,"Argument Seperator",IsArrayColSeperator,"Array Column Seperator",IsArrayRowSeperator,"Array Row Seperator",IsWhiteSpace,"White Space",TRUE,"Term"), TokenTypePass2, IF(SCAN(0,TokenTypePass1,LAMBDA(tot,x,SWITCH(x,"Term",0,"Open Paren",1,"Argument Seperator",1,"Array Row Seperator",1,"Array Column Seperator",1,"Operator",tot 1,tot)))>1,"Term",TokenTypePass1), TokenIndex, SCAN(0,IF((INDEX(TokenTypePass2,SEQUENCE(ROWS(TokenTypePass2),,0))=TokenTypePass2)*(PriorChars<>"")*(((TokenTypePass2="Term") (TokenTypePass2="Comparison") (TokenTypePass2="White Space"))>0),0,1),LAMBDA(tot,x,tot x)), TokenTypes, LET(TokenTypeLookup,XLOOKUP(SEQUENCE(MAX(TokenIndex)),TokenIndex,TokenTypePass2),NextTokenType,XLOOKUP(SEQUENCE(MAX(TokenIndex)) 1,TokenIndex,TokenTypePass2,""),IF((TokenTypeLookup="Term")*(NextTokenType="Open Paren"),"Function",TokenTypeLookup)), Tokens, BYROW(SEQUENCE(MAX(TokenIndex)),LAMBDA(x,TEXTJOIN("",,FILTER(Chars,TokenIndex=x)))), Tokenized, MAKEARRAY(ROWS(TokenTypes),2,LAMBDA(x,y,IF(y=1,INDEX(TokenTypes,x),INDEX(Tokens,x)))), Tokenized )), tokens, TOKENIZEFORMULA(OFFSET(cell,0,0,1,1)), isterm, INDEX(tokens,,1)="Term", activesheetname, MID(CELL("filename",INDIRECT("$A$1")),FIND("]",CELL("filename",INDIRECT("$A$1"))) 1,999), cellsheetname, MID(CELL("filename",cell),FIND("]",CELL("filename",cell)) 1,999), isaddress, IFERROR(CELL("address",INDIRECT(INDEX(tokens,,2))),IFERROR(CELL("address",INDIRECT("'"&cellsheetname&"'!"&INDEX(tokens,,2))),""))<>"", relativetocell, INDEX(FILTER(tokens,isterm*isaddress),,2), relativetoactivesheet, IF(ISERROR(FIND("!",relativetocell)),IF(ISERROR(CELL("address",INDIRECT(cellsheetname&"!"&relativetocell))),"'"&cellsheetname&"'!",cellsheetname&"!")&relativetocell,relativetocell), removeactivesheet, IF((LEFT(relativetoactivesheet,LEN(activesheetname&"!"))=activesheetname&"!") (LEFT(relativetoactivesheet,LEN("'"&activesheetname&"!"))="'"&activesheetname&"'!"),MID(relativetoactivesheet,FIND("!",relativetoactivesheet) 1,999),relativetoactivesheet), precedents, UNIQUE(removeactivesheet), precedents ))
1
6
908
🔍 Exploring the Crypto Tokens! 🔍 1️⃣ Platform Tokens: The decentralized system's backbone ensures security in transactions! 2️⃣ Transactional Tokens: Digital to traditional cash. Swift, cost-effective & sometimes with perks! 3️⃣ Utility Tokens: Your ticket to blockchain services. Fueling platforms like Basic Attention Token & Golem! Dive deep, and remember - many tokens wear multiple hats! #CryptoEducation #TokenTypes #Blockchain #DoricNetwork
3
6
155
30 Aug 2023
X fam! 👋🏼 You've probably been hearing a lot about NFTs lately, and how they come in different flavors like ERC721, ERC20, and ERC1155. It can be a tad confusing, but don't worry – I've got your back! Let's break it down. 🎨💎 #NFTs #TokenTypes
14
1
7
108
24 Jun 2023
🌐 Types of Tokens ⚙️💡 ✨Utility Tokens: Access specific products/services ✨Security Tokens: Represent ownership/investment ✨Governance Tokens: Provide voting rights in blockchain networks. #TokenTypes #web3 #Cryptocurency
1
1
3
79
🌟 Ever wondered about Utility vs Security tokens? 🤔 Look no further! We've got the ultimate breakdown to help you navigate the crypto landscape 🌐💎 Don't miss out: smartblocks.agency/blog/expl… 🚀 #CryptoWisdom #TokenTypes #InvestWithConfidence 🌟

1
2
552
12 Feb 2020
#100DaysOfCode #CPlusPlus Day 3: Today I created basic error handling for my language. I added an enum TokenTypes for the various tokens in the lang (keywords like "func", operators like , =, !=, etc), then wrapped it all in a Token class which holds all the info about them.
3
2